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Geoprocessing Wizard Toolbox 
The Geoprocessing Wizard Toolbox from ArcGIS 8.3 has been replicated as a toolset in 
ArcGIS 9.0.  The Geoprocessing Wizard Toolbox can be downloaded from the ESRI 
Support website:   
http://support.esri.com/index.cfm?fa=downloads.geoprocessing.gateway 

You will be downloading a file named:  Geoprocessing_Wizard_Tools.tbx.   

The file should be copied to the following directory: 

C:\Program Files\ARCGIS\ArcToolbox\Toolboxes 

* (This will be copied into the root ArcGIS folder – the exact location will depend where on your 
harddrive the software was loaded.  For some, the ArcGIS folder will be found under the Program Files 
directory, for others it may be under a different folder name.  (Example - Apps, Software,) 

(Always, save a copy on a disk or in another directory on your computer for backup should you reload ArcGIS 
or remove the program) 

The Geoprocessing Wizard Toolbar has the same 5 tools that the original Wizard had in previous ArcView 
releases.     

 

To load the toolbox in ArcMap: 

 Right-click the ArcToolbox folder inside the ArcToolbox window and select Add Toolbox. 

 Click the Look in dropdown arrow and click Toolboxes. 
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 Click the 
Geoprocessing_Wizard_Tools. 

 Click Open. 

 

 

The Geoprocessing Wizard Toolbox is added to ArcToolbox .  The toolbox is added as a shortcut that points 
to the toolbox stored on disk. (If you give the map document to someone, the toolbox is not in the map 
document, but stored in the default location)  

 

 

 

The Geoprocessing Wizard Toolbox will not automatically be loaded every time ArcMap is opened unless the 
toolbox settings are saved. 

 

 Right-click the ArcToolbox folder inside the 
ArcToolbox window and select Save Settings. 

There are two options here.  One is to save it as a file, which will save the 
settings out to an .XML file, which can be loaded at a later time.  The 
other is to save it to default, which will cause the Geoprocessing toolbox 
to open with ArcMap each time it is opened. 

 

Tip:  Even though the Geoprocessing Wizard is no longer included in ArcGIS 9.0 as a wizard, the operations 
are still available in ArcToolbox as individual tools.  The tools are accessible in the following toolboxes in 
ArcToolbox: 

Dissolve: Data Management toolbox > Generalization > Dissolve 
Merge:  Data Management toolbox > General > Append 
Clip:  Analysis Toolbox > Extract > Clip 
Intersect: Analysis Toolbox > Overlay > Intersect 
Union:  Analysis Toolbox > Overlay > Union 
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Interchange Files 
 
Configure ArcCatalog to recognize ArcInfo interchange files 
 
By default ArcCatalog does not list ArcInfo Interchange files (.e00) in the catalog tree. 
 

 Open ArcCatalog 

 Click on Tools from the menu, select Options. 

 Select File Types tab. 

 Click New Type button. 

 At the File Extension Line, type e00.  
*Make sure to use the number zero, not the letter O. 

 At the File Description Line, type ArcInfo Interchange File. 

 Optional – Click on the change icon button to change to different icon 
representation. 

 Click O.K. 

 Click Apply>O.K. 

Import ArcInfo interchange files in ArcGIS 

 Open ArcCatalog. 

 Click on View from the menu>select Toolbars>Arcview 8.x toolbar. 

 The Conversion Tools toolbar will appear, and 
contains many conversion options, including import 
from interchange file. 

 
 *.e00 files can be 

imported 
individually or in 
batches. 
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Cartography 

Transparency – Vector & Raster 
In ArcView 3.x, there was a transparent symbol in the Symbol Palette.  In ArcGIS 9.0, a user needs 
to load a special toolbar to symbolize features as transparent.  In addition, a user can change the 
brightness of an image using this same toolbar.   

Go to View > Toolbars > Effects to load the Effects Toolbar 

 

 Choose Lakes under Layer 

 Click the Transparency button and move the slider bar to 50% 

You will see the municipal boundary through the lakes now 

 Check on the MrSID in your TOC 

 Choose MrSID under Layer in the Effects Toolbar 

 Click on the Brightness button  and adjust up and down. You will see the image change 
directly in the view. 

 

Clipping Data Frames 
A user can clip a data frame to specified extents for more refined 
mapping. 

 Double click your Data Frame > Click the Data Frame tab 
> Check Enable under Clip to Shape > Specify shape 

 Under Clip Shapes, select Outline of Features 

 Choose Layer  and Features 

Notice that you can also draw a custom graphic in your 
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view and clip to that graphic as well. 

 Click OK > OK 

This feature allows the user to make clean maps without having to go through a clipping process. 

Transparency – Legend 
Legends can display transparent fills, like the one applied earlier, but a few extra steps are needed. 

 In Arcmap, click Tools > Customize 

 Click the Commands tab > Categories =Page Layout > Commands= Eye Dropper 

 Click the Eye Dropper, drag and drop it onto a toolbar    

 Make sure you are in View mode 

 Click the Eye Dropper Tool you just added and click on a Lake in your View   

 Name your new color Lakes > OK 

 In Layout View, click the Select Elements tool  > right click the legend >Convert to Graphics 

 On the Draw Toolbar, click Drawing > Ungroup 

 Do the above step one more time  (this ungroups all the legend elements) 

 Select the Lakes polygon in the legend (now a graphic)  

 Click the Fill Color button  in the drawing toolbar and select the recently saved Lakes fill 
color 

Your legend now better represents the transparent color in your map 
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Templates 
Templates are used to set up default legends, text, scalebars, logos, etc in ArcMap layouts.  Once set 
up, they can be used over and over, eliminating the need to add and position standard layout 
elements. 

 Make sure you are in the layout mode. 

 Add layout elements such as a north arrow or scalebar using the Insert menu item.  

 Go to File > Save As 

 Navigate to C:\Program Files\ARCGIS\bin\Templates 

 Create a new folder > give it your name > double click on the new folder 

 Set the Save As Type = .mxt 

 Name your new template “Base” 

 Save 

 Click on your Change Layout button  

 Select the tab with your name 

Your newly created template is now shown.  You can create new templates in this same way 
and simply apply them using this button. 

Printing & Exporting Maps 
Here are some useful tips when printing or exporting maps 

1. Download all patches from the ESRI website 

2. To prevent clipping during printing, make your page size slightly bigger.  Make sure to uncheck 
scale map elements in the print/page setup dialog box. Or, uncheck “Use Printer Page Settings” 
and choose “Scale Map to Fit Printer Paper” when printing. 

3. Using picture markers, hatch or transparency fills may not export correctly.  Try increasing your 
resolution or exporting to a .eps file then use Acrobat to convert to a PDF. 

4. Exporting layouts as EMFs (Enhanced Metafile) produce the best image by retaining the color 
and clarity of an image. 
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Work Performance Tips 
ArcGIS brings new ways to manage everyday work activities.  Here are several tips that will 
help the day to day GIS user. 
 
 

Find & Replace Pathnames 
ArcGIS 9 allows a user to replace pathnames in batch, unlike in 8.x 

 
 Open ArcCatalog 

 
 Browse to the folder that contains the .mxd you want to change the pathnames in 

 
 Right click the .mxd, Select Set Data Source(s) 

 
            A list of pathnames for the associated data layers appears.  You can 
            Choose a new data source for a single layer or multiple layers. 
 

 Click Select All, then click Replace All 
 

 Set your “replace with” pathname to the location where the data is stored.  
 The mxd now points to the data layers in this location 
 
 
 
 

 Go to View > Refresh 
You will see a copy of the .mxd. 
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Grouping/Ungrouping Layers 
ArcGIS 8.x did not allow ungrouping of layers and the grouping function did not always maintain 
the desired order of layers.   

 
 In the Table of Contents, highlight all the features in your table of contents by holding 

down the shift key and selecting each one 
 

 Right click in the Table of Contents and Select Group Layers 
 

 Right click the new group layer > select Ungroup 
(This was not an option in 8.3) 

 

Data Frame Focus  
 
In layout mode, the focus button allows a user to work with features as if you were in data 
view. 

 Make sure you are in layout view by clicking on the Layout View button   
 

 If you try selecting a graphic or annotation using the Select Elements tool      
 
      You can’t do it because the graphics and/or annotation are associated with the data view 
 
 
 

 Click the Focus Data Frame button (or double click the dataframe)   
 

The outline of the dataframe change to a thicker outline 
 

 It is now possible to select and move the graphics because the layout view is acting as the 
data view. 

 
 Return to layout view by clicking anywhere outside the data frame or click the Focus Data Frame 

button again 
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New Layer Visibility 
 
Several personal preferences can be set directly in ArcMap.  Often times, you will be adding 
large datasets that take a long time to draw in ArcMap.  This can be frustrating as the ArcMap 
default is to activate a feature class as soon as it’s added.  You can change this however. 

 
 Go to <Tools<Options 

 
 

 Choose General > Uncheck New Layer Visibility 
 
 
 
 
 

 

Cancel Drawing 
There may be cases where you have large amounts of data that take a long time to load.  

 
 Click the Escape (Esc) button when you want to stop drawing 
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Pausing the Drawing in ArcMap 
This command is added to an ArcMap pulldown menu or toolbar to suspend (temporarily) all 
drawing in the ArcMap display.  When you pause the display drawing you can still work in the 
program.   

When you have an extensive symbology and/or a display with a large, slow drawing image, this 
allows you to make changes to the symbology for a number of layers without having the map redraw 
each time you okay the symbol changes for each layer.  

 In ArcMap, right click in the blank area of a toolbar bar at the top of the 
ArcMap window. 

 
 Scroll down to the bottom of the context menu and select Customize. 

 
 Click on the Commands tab. 

 
 Click on the Pan/Zoom in the Categories list 

and click and drag Pause Drawing from the 
Commands list onto a toolbar. 

Note:  As you hover over a toolbar you 
will be able to drop the Pan/Zoom tool 
when you see the I 

 
 
 
 
 
 

 
Tip: Remove a tool by opening the Customize window (as outlined in the above 
steps) and dragging the tool from the toolbar back to the Customize dialog. 

 
 
 

Removing Buttons 
 Open your customize dialog box (see above) 

 Click and drag the Pause Drawing button into the white space of the customize dialog box 
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Create a circle with a specific radius 
 

 Open ArcMAP. 
 

 To add the toolbar, click on View menu>Toolbars>Advanced Editing.  
 

 Add an editable polygon shapefile. 
 

 Click on the Editor Toolbar >select Start Editing. 
 

 Click on the Circle Tool on the Advanced Editing Toolbar. 
 
 

 Click on the 
map to specify the center of the circle. 

 
 Hit the ‘R’ key on the keyboard. 

 
 Specify radius of the circle, hit the return key. 

 
*Be sure to set up the map units in the Data Frame Properties. The radius will be 
drawn in the units that the map is set in. (Feet, Meters, Inches.) 
 

*Clicking on ‘R’ on the keyboard before clicking on the screen to specify center   
  of circle will cause ArcMap to close. This is a known bug. 

 
 

Calculating the area for a polygon graphic in ArcMap 
 
 The first step will be to create a new UIButton Control. 

 Open existing .MXD you want to work in, or 
create new. 

 
 Click the Tools menu and click Customize.  

 
 Click the Commands tab.  

 
 Click the Save in dropdown arrow>click  

<name of mxd here>.mxt. 
 

 Click UIControls in the Categories list. 
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 Click New UIControl. 

 
 Click UIButtonControl. 

 
 Click Create to create the 

control without attaching code 
to it.  In this example we want to create a button. 

 

 Click the newly created UIControl, click it again to activate in-place editing, and 
type a new name for the control.  

 Click and drag the newly created UIControl and drop it on a toolbar or menu.  

 On the toolbar or menu, right-click the command to set its image, caption, and other 
properties.  

 
 Right-click the new command on the toolbar or menu, then click View Source.  

 
 The Visual Basic Editor appears, displaying the control's code in the Code 

window.  
 

 Click the Procedures Box dropdown arrow and select Click. 
 
 
 
 
 
 

 
 

 Type code for the event procedure. This needs to be placed between the existing lines of 
Private Sub and End Sub.  In many cases the code can be copied and pasted 
into the code. 

 
CODE: 
 Dim pApp As IApplication 
Set pApp = Application 
 
'-- Get the map document 
Dim pDoc As IMxDocument 
Set pDoc = ThisDocument 
 
'-- Get the graphics container for the active view 
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Dim pAv  As IActiveView 
Set pAv = pDoc.ActiveView 
Dim pGc As IGraphicsContainerSelect 
Set pGc = pAv.GraphicsContainer 
 
'-- Make sure only one element is selected 
Dim pElem As IElement 
If pGc.ElementSelectionCount > 1 Then 
  MsgBox "Only one element can be selected" 
  Exit Sub 
End If 
 
'-- Get the area for the selected element 
Dim pPoly As IPolygon 
Dim pArea As IArea 
Set pElem = pGc.SelectedElement(0) 
If TypeOf pElem.Geometry Is IPolygon Then 
  Set pArea = pElem.Geometry 
  '-- Send the area to the status bar 
  pApp.StatusBar.Message(0) = "Element Area : " & pArea.Area 
  '-- or a message box 
  MsgBox "Element Area: " & pArea.Area 
End If 

 
 Click Save in the Visual Basic Editor.  

 
 Click the Close button in the Visual Basic Editor.  

 
 Select a polygon graphic and click the newly created button. 

 
 The area will be reported in a pop-up window. 

  
 
 
 

 

 
 

 

*After getting the area, it can be calculated into acres with a simple calculation. 
Divide by 43,560 for acres in square feet. 
Divide by 4046.8659 for acres in square meters.
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Count the features within an area 
 
  The first step will be to create a new UITool Control. 

 Open existing .MXD you want to work in, or 
create new. 

 
 Click the Tools menu and click Customize.  

 
 Click the Commands tab.  

 
 Click the Save in dropdown arrow>click  

<name of mxd here>.mxt. 
 

 Click UIControls in the Categories list. 
 
 

 Click New UIControl. 
 

 Click UIToolControl. 
 

 Click Create to create the control without attaching code to it.   
o In this example we want to create a tool, to click and drag a rectangle around the features 

to be counted. 
 

 Click the newly created UIControl, click it again to activate in-place editing, and 
type a new name for the control.  

 Click and drag the newly created UIControl and drop it on a toolbar or menu.  

 On the toolbar or menu, right-click the command to set its image, caption, and other 
properties.  

 
 Right-click the new command on the toolbar or menu, then click View Source.  

 
 The Visual Basic Editor appears, displaying the control's code in the Code 

window.  
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 Click the Procedures Box dropdown arrow and select MouseDown. 

 
 
 
 
 
 
 
 
 
 
 

 Type, or copy and paste code between the Private Sub and End Sub existing lines 
of code. 

 
 
CODE: 

 
Dim pMxDoc As IMxDocument 
Set pMxDoc = ThisDocument 
 
Dim pEnv As IEnvelope 
Dim pRubber As IRubberBand 
Set pRubber = New RubberEnvelope 
 
Dim pActiveView As IActiveView 
Set pActiveView = pMxDoc.FocusMap 
Set pEnv = pRubber.TrackNew(pActiveView.ScreenDisplay, Nothing) 
 
Dim pSpatialFilter As ISpatialFilter 
Set pSpatialFilter = New SpatialFilter 
Set pSpatialFilter.Geometry = pEnv 
pSpatialFilter.SpatialRel = esriSpatialRelIntersects 
 
Dim lPoints As Long, lPolylines As Long, lPolygons As Long 
Dim pLayer As IFeatureLayer 
Dim pFeatureCursor As IFeatureCursor 
Dim pFeature As IFeature 
Dim i As Long 
For i = 0 To pMxDoc.FocusMap.LayerCount - 1 
  If (TypeOf pMxDoc.FocusMap.Layer(i) Is IGeoFeatureLayer) Then 
     Set pLayer = pMxDoc.FocusMap.Layer(i) 
     pSpatialFilter.GeometryField = 
pLayer.FeatureClass.ShapeFieldName 
 
     Set pFeatureCursor = pLayer.Search(pSpatialFilter, True) 
     Set pFeature = pFeatureCursor.NextFeature 
     Do Until (pFeature Is Nothing) 
       Select Case pFeature.Shape.GeometryType 
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         Case esriGeometryPoint 
           lPoints = lPoints + 1 
         Case esriGeometryPolyline 
           lPolylines = lPolylines + 1 
         Case esriGeometryPolygon 
           lPolygons = lPolygons + 1 
        End Select 
        Set pFeature = pFeatureCursor.NextFeature 
     Loop 
  End If 
Next i 
 
MsgBox "Features Found:" & vbCrLf & lPoints & " Points " & vbCrLf & 
_ 
lPolylines & " Polylines " & vbCrLf & lPolygons & " Polygons " 
 
 
 

 Click Save in the Visual Basic Editor.  
 

 Click the Close button in the Visual Basic Editor. 
 

 Click the button in ArcMap, click and drag to select area where to count the 
features. 

 
 A pop-up box will appear with the number of counted items. 
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Tables 
Whether it is a .dbf  from a Shapefile or a PC ArcInfo Coverage, an info file 
from an ArcInfo coverage, or a MS Access table, creating and editing tables is 
an intricate part of  the day to day tasks in GIS.   

Tables can be manipulated in ArcMap, ArcCatalog, and through the ArcToolbox in ArcGIS.  How 
the tables are accessed and edited will depend on the needs of the task to be accomplished and the 
preferences of the technician.    

Here are a few tips that will make working with tables in ArcGIS a little easier: 

 Some characters in field or table names are not supported. 

o Names must not have a space. 

o Names must not have a hyphen. (Example x-coord) 

o Names must not have brackets. 

o Names must not have special characters. (# * / ~) 

o Names must not start with a number or underscore. 

 Field names in delimited text files must be edited to remove these unsupported 
characters before using them. 

 Tables that contain Memo fields cannot be accessed in ArcGIS. 

 Field and table names can be 31 characters for Geodatabase feature classes. 

 A dBASE field name can be up to 10 characters long. 

 A dBASE table name has no limit to the length. 

 Up to 16 letters or numbers can be used in coverage field and table names.  
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Generating a report 
 
Sometimes all that is needed is a simple report without a lot a frills.  In this example, a report 
will be created that contains the city name, elevation, and population of each city from the 
Census Data table. 
 

 In the Tools dropdown menu>click Reports> Create 
Report. 

 The Report Properties dialog box will open. 

 Under the Fileds Tab, Click on the Layer/Table 
dropdown box, select Population. 

 Under Available Fields: double click on Feat_Name, 
Elevation, and Population to bring them over to the 
Report Fields heading. 

 Under the Sorting Tab, Click under the Sort 
column for Feat_Name, select Ascending from 
the dropdown box. 

 Click on the Generate Report button. 
 
 

 
 The Report View will open with the generated report. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Click on the X in the upper right corner to close report. 

 Click on the close button on the bottom of the Report Properties dialog box. 

 Click on NO to exit without saving. To save this report, click on the yes button and 
it can be saved out to a .rdf file for later use. 
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Creating a Table 
  
In ArcGIS a new table can be created either through ArcCatalog or through the ArcToolbox in 
ArcMap. 

 

 When adding a field type of double, as you would with an acres field for example, 
there are two parameters that need to be filled in.  One is Precision the other 
Scale. 

o Precision – Is how long in length the entire field will be. (Including one 
place holder for the decimal). 

o Scale – Is how many decimal places are needed. 

*Although both Double and Float types allow for decimals, Float fields only allow up 
to seven significant digits for storage, while Double will allow up to 15 digits for 
storage. 

 

 

Editing and Calculating Fields in a Table 
There are two basic ways that field items can be edited and calculated in ArcMap.  Inside of an 
edit session and outside of an edit session.  Editing outside of an edit session consists of 
opening up the table you wish to make edits on, right clicking on a field header and selecting 
calculate values.  You will get a message stating that you are about to make a calculation outside 
of an edit session, do you wish to continue?  Although this is the quicker way to calculate fields, 
especially on extremely large datasets, there is no way of undoing the edits.  The changes are 
automatically saved.   

The other way of editing and calculating fields involves working within an edit session.  This 
way of editing allows for the option of not saving edits if a mistake was made.  Unless you are 
very confident in your abilities, and make daily back-ups of the data you routinely work with, 
working within an edit session is highly recommended. 
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Using VBA statements in table calculations:  Example calculating acreage. 

 Right click on Shapefile>go to Open Attribute Table. 

 Click on the dropdown box of the Editor toolbar. 

o If the editor toolbar is not turned on- 

 Right click anywhere in the gray 
area. 

 Check on the Editor toolbar. 

 Dock the toolbar towards the top of the screen. 

 Click on the Start Editing option. 

o The table is now in editing mode. 

 Right click on the top of the Area Field. 

 Go to Calculate Values.   

 The Field Calculator dialog box will open. 

 Check on the Advanced button. 

 Type the following VBA statement in the first box. 
 

    Dim dblArea as double 
    Dim pArea as IArea 
    Set pArea = [shape] 
    dblArea = pArea.area 

 Type dblArea in the text box directly below. 

 Click OK. 
 
Saving VBA statements from table calculations:   
 

 Before clicking on the OK from the above step - 
 

 Click on the Save button. 
 

 Browse to folder to save file in. 
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 Name the file (from above for example) Area.cal > Click Save. 
 
 
 
 
 
Loading VBA statements into table calculations:   
  Example calculating length. 
 

 Right click on Line Shapefile>go to Open Attribute 
Table. 

 Click on the dropdown box of the Editor toolbar. 

 Select Start Editing. 

 Right click on the Length field. 

 Select Calculate Values. 

 In the Field Calculator, click on the Load button. 

 Browse to folder that contains the saved calculation files.  (For this example we 
are selecting length.cal.) 

 Click Open. 

 Click OK. 

 Close attribute of line shapefile. 

 Click on the dropdown box from the Editor Toolbar, select Stop Editing. 

 Do you want to save your edits?  Click Yes. 

 

 

 
 
 
 
 
 
 

*The saved VBA statement can now be called on to calculate the area of future datasets. 
For calculations that are done often, this can be a time saver. 
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Common Calculation Formulas 
 Updating perimeter for Shapefile: 

 
Right-click the field heading for the Perimeter field and click Calculate Values. 
 
 Type the following VBA statement in the first box. 

 
     Dim dblPerimeter as double 
     Dim pCurve as ICurve 
      Set pCurve = [shape] 
      dblPerimeter = pCurve.Length 
 

  Type dblPerimeter in the text box directly below. 
 

 Updating area for Shapefile: 
 

 Right-click the field heading for the Area field and click Calculate   
 Values. 
 
 Type the following VBA statement in the first box. 

    
    Dim dblArea as double 
    Dim pArea as IArea 
    Set pArea = [shape] 
    dblArea = pArea.area 
 
           Type dblArea in the text box directly below. 
   
 

 To add the x coordinate of points: 
 

Right-click the field heading for the X field and click Calculate Values. 
 
Type the following VBA statement in the first box. 
 

Dim Output As Double 
Dim pPoint As IPoint 
Set pPoint = [Shape] 
Output = pPoint.X 
 

  Type dblX in the text box directly below. 
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 To add the Y coordinate of points:  
 

Right-click the field heading for the Y field and click Calculate Values. 
 
Type the following VBA statement in the first box. 
 

        Dim dblY As Double 
        Dim pPoint As IPoint 
        Set pPoint = [Shape] 
        dblY = pPoint.Y 

Type dblY in the text box directly below. 

Some common field calculations: 
 

 [Field Name] & [Field Name] & [FieldName] 
Concatenates multiple fields into one.  
Example:  [Township] & [Range] & [Section] 

 [Field Name] & “ “ & [Field Name] & “ “ & [Field Name] 
Adds spaces between the values being concatenated. 

 LCase ( [Field_Name] )  
Makes all characters in a field lowercase. 

 UCase ( [Field_Name] ) 
  Makes all characters in a field uppercase. 

 Left ( [Field_Name] , 3) 
  Truncates the left-most characters in a field. 

 Right ( [Field_Name] , 4) 
Truncates the right-most characters in a field. 

 Mid ( [Field_Name], 4 , 3 ) 
Returns the mid three characters starting at the fourth placeholder. 
 

 LTrim ( Field_Name ) 
Trim leading blanks from a string. 
 

 RTrim ( Field_Name ) 
Trim trailing blanks from a string. 
 

 NOW( )   
Calculates the current date into a field.  



A R C G I S  T I P S  &  T O O L S  
E S R I  W I S C O N S I N  U S E R S  G R O U P  2 0 0 4  
 

 25

Shortcuts  
 

ArcGIS 9 ArcMap has many shortcuts that make accessing commands, 
navigating and selecting a snap for keyboard enthusiasts.   

Selecting items in the table of contents. 

 Ctrl + click selects or deselects multiple layers or data frames 

 Shift + click selectsall layers or data frames between two layers or data frames, within the same 
table of contents level 

 

Navigate the table of contents with the computer keyboard. 

 Esc or click the map puts the keyboard focus on the map 

 F3 or clicking inside the table of contents puts the keyboard focus on the table of contents 

 Home selects the first item in the table of contents 

 End selects the last item in the table of contents 

 Up/Down arrows move through the items in the table of contents 

 Left/Right arrows or the + and – keys expands or contracts selected items.  Left/Right 
arrows and + and – keys also switch between the tabs at the bottom of the table of contents 
when they have keyboard focus. 

 Spacebar turns drawing of the selected layer(s) on or off. 

 F2 renames the selected item. 

 Double Click on an item or F12 opens the selected item’s properties dialog box. 

 Alt and click a data frame to activate it or F11 activates a selected data frame. 

 Shift + F10 opens the context menu for the selected item. 
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Using mouse shortcuts in the table of contents 

 Ctrl + Click an expansion control (=/- to expand or contract all the items at that level.  If any 
items are currently selected, only the selected items are expanded or collapsed. 

 Ctrl + Click a check box to turn all the layers on or off at that level.  If any items are currently 
selected, only the selected items are turned on or off. 

 When dragging layers, hovering over an expansion control with the drop pointer expands or 
collapses any item. 

 

Docking and undocking 

 Hold down Ctrl while dragging a toolbar or dockable window to prevent it from docking. 
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Thumbnails 
 

A thumbnail is a snapshot describing the geographic data contained in a data source or layer, or 
a map layout. Thumbnails are not updated automatically; they will go out of date if features are 
added to a data source or if the symbology of a layer changes.  You must create and update 
thumbnails manually.  Thumbnails are stored in the item’s metadata. 

 

 From the top of the toolbars in ArcMap, click on the 
ArcCatalog button.  

 In the Catalog tree, click the layer you want to create a thumbnail. 

 Click the Preview tab. 

 Click the Zoom In button on the Geography toolbar and zoom to an area 
that represents the layer’s contents. 

 Click the Create Thumbnail button.   

 The thumbnail records what you 
currently see in the Geography view. 

 

You also have the option of having ArcMap save a 
thumbnail of the current view extent when saving the map 
document. 

 Click on >File>Map Properties. 

 

 Check on Save thumbnail image with 
map. 

 
 
 
 
 
 
 


